Using date ranges in the x axis and how to avoid hyphens or en dashes turning into full stops

We’ve found in the last few years of using Everviz that when we upload date ranges in the data, e.g. 2022–23, Everviz replaces the en dash or hyphen with a full stop, and instead displays them as 2022.23. We use date ranges a lot as our x axes often use financial years.

The workaround we’ve used to avoid this so far is including a space either side of the en dash, so it looks like 2022 – 23, which displays as written. However, Martin has suggested a longer-term fix to this bug may be possible. For now, including his custom code below resolves the issue:

Highcharts.merge(true, options, {
  data: {
     itemDelimiter: ';'

We can add this to individual charts, but cannot yet build this fix into our themes as we can’t include custom code for them. In the meantime, hope this custom code is helpful!


Awesome, thanks for sharing the fix. And very nice to see you here on the forum :blush:

1 Like